When I upload my Blender file Blend-Exchange I get a message saying my file is not a blend file. Why?

enter image description here


2 Answers 2


This is a known issue: https://github.com/GiantCowFilms/Blend-Exchange/issues/56, which has now been resolved. I apologize for the slow response in getting this addressed.

  • 2
    $\begingroup$ You are awesome! People like you make the world a better place. Much gratitude! $\endgroup$
    – Mentalist
    Mar 7, 2022 at 2:54

Where did you upload? That looks like blend-exchange. If it is, you have probably tried to upload a compressed 3.x file. For some reason, blend-exchange sometimes doesn't recognize the new compression algorithm. Try uploading without compression.

  • 1
    $\begingroup$ Probably compression is not the only one reason ... I tried several 3.1 without compression now, with this error ... imgur.com/2CfdBdh $\endgroup$
    – vklidu
    Feb 25, 2022 at 19:21
  • $\begingroup$ I have been experiencing the same internal error every time I try to upload recently. For now, we can use PasteAll, but it's only temporary hosting (about 5 months). Hopefully @GiantCowFilms will be able to resolve it soon. Our community really benefits from Blend Exchange. $\endgroup$
    – Mentalist
    Mar 4, 2022 at 1:10
  • $\begingroup$ @Mentalist Issue is now fixed, I apologize for how long this took to be addressed... my (multiple :( ) jobs are quite demanding right now. $\endgroup$ Mar 7, 2022 at 1:18
  • $\begingroup$ @GiantCowFilms You are doing this community an incredible service. You never need to apologize for how long it takes you to cope with changes in Blender's implementation. $\endgroup$ Mar 7, 2022 at 1:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .