0
$\begingroup$

Update

This issue seems to be only on the M - MX family. Desktop GPUs aren't affected.

Due to the influx of the "Blender is lagging" posts, I'm going to pin this on the main site until the issue is resolved, and our close-votes review queue calms down. From what I've seen only 2.78 users are posting but it might affect other versions as well.

See Blender 2.78 with Windows 10 lags when interacting with the UI and the official release thread for the driver is here https://forums.geforce.com/default/topic/978895/geforce-drivers/official-376-09-game-ready-whql-display-driver-feedback-thread-released-11-28-16-/1/

DO NOT UPDATE TO Official 376.09 Game Ready WHQL Display Driver (Released 11/28/16).

If you have already, the best "fix" is to rollback to your previous working driver, personally 375.95 seems to be a good version in the same month. If for some reason you can't do this, open the NVIDIA control panel and force Blender to use the intel chipset, if you have that option (not recommended as you might see flickering).

Can we add a tag for these sorts of questions?

It seems like there are lots of questions about strange behaviors in blender that are "driver" issues, but I'm not sure that this tag is sufficient because "drivers" in blender are completely different than drivers in your OS.

Please add your thoughts on what tag (if any) we should add for these questions.

$\endgroup$
3
  • $\begingroup$ we have a hardware tag. $\endgroup$
    – David
    Dec 4 '16 at 14:36
  • $\begingroup$ @david drivers aren't hardware. $\endgroup$
    – 10 Replies
    Dec 4 '16 at 14:38
  • 2
    $\begingroup$ true, but most of the question we are getting are asking about the graphics card. It is only after the question is answered does the the OP learn it is a drivers issue. $\endgroup$
    – David
    Dec 4 '16 at 14:49

You must log in to answer this question.

Browse other questions tagged .